After Humanoid animation clip converted to Generic, it went wrong by missing some frame

Haiyang Qi 9 years ago updated by tmpxyz 9 years ago 7
Humanoid animation clip works well, and after I converted it into Generic, it went wrong..
These two pics show how humanoid animation clip worked
Image 25
Image 26

and these two are Generic animation clips
Image 27

Image 28
The soldier just keep one action and flow forward ;)

after converted, many frames lost

Image 29

Image 30

The editor version is 5.1.2. Is that the reason I failed?
Under review
Hi, Haiyang Qi,

Thanks for your feedback,

I've just checked it again with an random animation from RawMocapAnimation pack on Unity5.1.0f3, and I cannot reproduce this issue. Maybe there's something special in the clip? Did you notice any error log after the conversion?

Maybe you could refer to the video and the checklist below to check if there's something special happened during the process?
* Is the source clip in Humanoid format?
* Is the source clip put into the AnimationController of a Humanoid rig model?
* Is the converter option set to Generic?
* Is the target model of Generic rig?

If this issues persists, could you send the animation to me so I could test it on my machine?

Best regards, Be creative,
Hi Tmpxyz,
I've done the same as you did in the video. Put the humanoid-character in the slot of converter, set to generic and click the button. Then put the converted-to-generic animation clip into the animator, and put the animator into the generic-character. I used the "HumanoidRun" animation of Ethan, the animation example character of standard asset which Unity provides, is that the reason why I failed?

Update editor log here.
Hold on for a while, let me take a try.
Just converted the "HumanoidRun" animation on Unitychan model, everything works fine here. So it's not on the clip part.

If the operation steps are executed in the right way, then there might be something on the soldier model.
* Are there any joints on the model that have the same names? it could cause trouble.

You could send me the soldier model if the issue persists.

Best regards,

Hi Tmpxyz!
Problem solved, I just found that I'd using the version 1.8.0 skele, and changed it into the latest version.
....and problem solved. The convert went perfect.

So sorry to bother you a lot. And thanks, tmpxyz.
Glad to hear the problem solved, =)

If you have found any other issue, just tell me.