0
Not a bug

Compile Errors auf Import to Unity 5.3.5f1

wohltaeter 6 years ago updated by tmpxyz 6 years ago 3

Hello, I have imported Skele and I have a lot of Compile Errors in AnimatorData.cs e. g. this line: public void Execute(AMTake take, bool isFrame = true, float value = 0f /* frame or time */)

The error msg says: Standardparameterdesignator are not allow and it points to the = in different lines.


Can you please help me?


Best regards

Under review

Hi, Wohltaeter,


Thanks for your feedback :)


I've just tested on Unity5.3.5f1, it seems fine here, no compilation error.

You can see the screenshot below:



Could you give more details on the errors you've seen?

1. What OS are you using(Win10/OSX)?

2. What build setting are you using (Webplayer/Standalone/iOS/Android) ?

3. Did you see it in Unity Console or in MonoDevelop's console?

(if in MonoDevelop, please check this thread on how to change the MonoDevelop setting)

4. Please try starting a new project, import only the Skele pacakge and see if the errors pop up in UnityConsole;

(This is used to check if there's other 3rd-party plugin name-colliding with us)


If the issue persists, please post the FULL stacktraces of some of the error logs from the UnityConsole, that would be very helpful for me to tell exactly what happened.


Best regards,



Hi and thanks for the reply. - The problem is solved. It was:

1. Win10

2. PC Standalone

3. Mono - And the thread helped to solve the issues.


Thanks again and Skele is a great product. - Keep up the great work!


Best regards,

Not a bug

Hi, Wohltaeters,


Great to hear that :)


If you ever encounter any other issues or have some suggestion, please don't hesitate to tell me,



Best regards,